• 2
  • 0
  • 1

Witam.

Chciałbym policzyć średnią dla trzech ostatnich kwartałów i przygotowałem do tego odpowiednie zakresy. Po wprowadzeniu funkcji średnia.warunków, dla jednego liczy się dobrze, po wprowadzeniu kolejnego pojawia się błąd. Próbowałem różnych opcji i czuję, że błąd zapewne jest banalny. Przykład w załączniku. 

Istotne jest to, że średnia ma być z trzech łącznie, a nie średnia z średnich kwartałów. 

Może ktoś spotkał się z tym zagadnieniem.

Pozdrawiam.
MS.

 

Załączniki

  • xlsx

    Przykład.xlsx ( 14K )
MateuszSawicki
  • Zapytał
  • @ MateuszSawicki | 10.04.2018
    • 0
    • 0
    • 0

Odpowiedzi (2)

  • 0

W tej funkcji wszystkie warunki muszą być spełnione. A w pojedynczym wierszu spełniony jest warunek 1, 2 lub 3.

Nie ma chyba funkcji wbudowanej, która policzyłaby taką średnią.

Tomasz_Kasprzycki
  • Odpowiedział
  • @ Tomasz_Kasprzycki | 10.04.2018
    • 2
    • 4
    • 8
  • 1

Funkcja tablicowa (zatwierdź przez ctrl+shift+enter):

=SUMA(JEŻELI.BŁĄD(JEŻELI(PODAJ.POZYCJĘ($E$5:$E$30;$I$3:$I$6;0);$F$5:$F$30);""))/SUMA(LICZ.JEŻELI($E$5:$E$30;$I$3:$I$6))

Oraz teoretycznie prostsza wersja, aczkolwiek z dwoma warunkami:

1) Kolumnie z kwartałami oraz z warunkami (komórki E4 i I2) trzeba nadać ten sam nagłówek (np. kwartał).

2) Zakres w trzecim argumencie funkcji nie może zawierać pustych pól (uśredniane kwartały zawsze muszą być jeden pod drugim, zakres zaczyna się na nagłówka i kończy na ostatnim z listy).

=BD.ŚREDNIA($E$4:$F$30;2;$I$2:$I$6)

Środkowy argument (2) wskazuje numer kolumny z liczbami do uśrednienia z zakresu w pierwszym argumencie. Kolumnie tej można również nadać nazwę i użyć jej zamiast dwójki. Ciekawym przykładem użycia tej właściwości może być wskazanie zakresu C5:F30 jako bazy, nazwanie kolumny z liczbami (F4) np. ile, a kryteriów (I2) np. Q. Wynik formuły będzie zależał od tego, w której komórce z zakresu C4:E4 wpiszemy później Q.

=BD.ŚREDNIA($C$4:$F$30;"ile";$I$2:$I$4)

Oczywiście przy kwartałach ma to - nomen omen - średni sens, ale może to być przydatne np. przy wyliczaniu średnich przychodów Klientów zajmujących pierwsze x miejsc według różnych kategorii, gdzie miejsca w tych kategoriach wpiszemy w kolumnach C:E.

Mirosław_Janiak
  • Odpowiedział
  • @ Mirosław_Janiak | 10.04.2018
    • 1
    • 7
    • 1